Posts Tagged Asus

WiFi not working on Asus T100TA

Today I ran into an issue with my Asus Transformer T100 where the Wi-Fi would not work under Windows 10 and going into Device Manager showed an issue with the Broadcom Serial Bus Driver over UART Bus Enumerator. Opening that shows “This device cannot start. (Code 10)” and the following message:

{Drive not Ready} The drive is not ready for use; its door may be open. Please check drive %hs and make sure that a disk is inserted and that the drive door is closed.

The first thing you will want to do to try to resolve this is to go into the BIOS by shutting the tablet down and then holding volume down + power to boot up into the BIOS. Once there, find “Network Stack” and set it to “Enabled” if it is not already. Save changes and exit.

If this does not resolve your issue, use a working system to download the drivers from Asus’ website and then transfer them to the Asus using a USB stick so you can reinstall the drivers. Optionally, you can use a USB-to-Ethernet adapter to get yourself back on the network and update the drivers.

At this point you should have resolved this. If not, go back and start over to ensure you followed the previous steps correctly. If it’s still not working, you should either restore to a previously-working restore point or reset/reinstall Windows. If that doesn’t help, you may have a hardware issue, so reach out to Asus for further support.

Advertisements

,

Leave a comment

Fixing wireless issues on Asus T100

I’ve seen issues with the Asus T100 where the Wi-Fi will frequently not reconnect after coming out of standby, hibernate, or a power off. Toggling airplane mode or rebooting the device will fix it, but not always the first time.

I found a fix for this, after reviewing the fix for frequently disconnecting Bluetooth devices, and the issues appear related.

Again, go into device manager and right-click the wireless network adapter, and click Properties. Go to the Advanced tab and change Minimum Power Consumption to Disabled.

Broadcom_Minimum_Power

After doing this, no more Wi-Fi issues!

, ,

Leave a comment